Upgrade to PRTG 24.3.100
Scheduled for Oct 7, 07:00 - 16:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 30, 2024 - 14:17 UTC
Scheduled
All hosted PRTG instances will be queued for being updated during this maintenance window. Instances will be unavailable for less than 15 minutes during the actual update process.

Starting with this release all PRTG Hosted Monitor webservers will be using a certificate issued by Let's Encrypt. Certificates issued by Let's Encrypt are valid for a shorter period, so we replace them with each update in the future as well.
Posted Sep 30, 2024 - 14:14 UTC
This scheduled maintenance affects: PRTG Instances (PRTG Servers).