Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 14, 2025 - 07:00 UTC
Update
Fixed incorrect date in description for planned second rollout on Wednesday, 16-April 2025.
Posted Apr 09, 2025 - 14:49 UTC
Scheduled
As of PRTG 25.1.104, a new trusted certificate authority signs the binary of PRTG.
This rollout is an intermediate update to PRTG version 25.1.104.1906 in order to ensure automatic updates of classic remote probes not failing due to the changed signing certificate.
For providing you then with the actual latest version 25.1.104.1961, containing all the latest features and fixes, we aim for another rollout on Wednesday, 16-April 2025. There will be a separate email coming about that rollout, after the rollout of the intermediate version has finished.
Updating your server should take around 15 minutes. Once complete, all classic remote probes will be automatically updated.
Posted Apr 09, 2025 - 13:50 UTC
This scheduled maintenance affected: PRTG Instances (PRTG Servers).